Microsoft Update List for Hyper-V

Posted by Ahmed Nabil In | 0 comments»

A lot of IT Professionals are moving to Hyper-V and they need to keep updated with all Hyper-V hotfixes, updates and Service Packs. The Below links are for Hyper-V on both Windows 2012 and Windows 2008R2. Some of these updates/fixes are intended to fix specific problem, so don’t apply them unless you have this specific issue. 

1.       Windows 2008R2 Hyper-V

 

2.       Windows 2012 Hyper-V 

 
Thanks to the above wiki creators.

UAG 2010 File Access application fails to open/start after UAG 2010 SP3 implementation

Posted by Ahmed Nabil In | 0 comments»

After the install of UAG 2010 SP3, all of the portal applications worked fine except for the File Access application. I tried several options with the application, removing it and adding it back but never worked till I asked my friend Ben Ari (UAG Senior Escalation engineer) as I thought it was depreciated. It turned out to be a glitch or bug after implementing the UAG 2010 SP3 and to fix you need to do the following:
 
1.       On the UAG server, Navigate to the following folder under UAG installation folder \Microsoft Forefront Unified Access Gateway\von\FileAccess

2.       Edit the file “default.asp” (I took a backup first before any change)

3.       Modify the word cint to parseInt on Line 20 (Or you can search the file as it appears once). Make sure that the “I” in “parseInt” is written in caps (Check below screenshot)
 
 

4.       Save and activate your Forefront UAG

 It should be noted that incase there are more than one UAG server in the array, this change should be applied on all servers manually by the same method and steps above.

UAG 2010 Portal error 403.14 after applying UAG 2010 SP3

Posted by Ahmed Nabil In | 0 comments»
The UAG 2010 SP3 was officially released on Feb 20, 2013 as promised by the UAG team to resolve several issues mainly to support Microsoft new systems and applications (Windows 8, Server 2012, Exchange 2013, SharePoint 2013...............etc). Thanks UAG team.

Download Link:  http://www.microsoft.com/en-us/download/details.aspx?id=36788

Release Notes: http://support.microsoft.com/kb/2744025


I will discuss my SP3 installation process and my comments for a successful implementation in another Post. One of the main issues that i faced after the installation of the UAG 2010 SP3 was that all my users were unable to access the UAG Portal page or any published site on the UAG (Mail OWA, SharePoint............etc) and the following error is Displayed:

Forbidden Directory, Listing Denied Error code 403.14

Microsoft has a good KB that deals with this error (http://support.microsoft.com/kb/961172) however in my case i needed to reboot the IIS later on. The Steps done to fix this issue is as follows:


  1. Open Forefront UAG management on the UAG server.
  2. Open/Explore the Trunks under the HTTP and/or HTTPS connections.
  3. Right click each Trunk and select Disable.
  4. Save and Activate the UAG configuration.
  5. Right Click the trunks again and select enable.
  6. Save and Activate the Configuration again.
  7. Open the IIS Manager
  8. Highlight your server name and from the actions hit restart to restart the IIS. This should do the trick.

Hopefully this should help anyone facing this problem after UAG SP3.